OpenGL 3.2 or higher now required for 09/30/2018 update

Found a bug? Great! Post about it here!

OpenGL 3.2 or higher now required for 09/30/2018 update

Postby ShinQuickMan » Tue Oct 02, 2018 6:40 pm

Got this message printed in Player.log in the latest build:

Code: Select all
Desktop is 1366 x 768 @ 60 Hz
Unable to find a supported OpenGL core profile
Failed to create valid graphics context: please ensure you meet the minimum requirements
E.g. OpenGL core profile 3.2 or later for OpenGL Core renderer
Forced renderer 17 is not supported, exiting
 
(Filename:  Line: 538)


If I'm understanding this correctly, games built on Unity 2017 do not support machines with graphics cards incompatible with OpenGL 3.2 or higher. As someone who lacks such a computer, that's quite a misfortune indeed.
ShinQuickMan
 
Posts: 5
Joined: Tue Oct 02, 2018 6:25 pm

Re: OpenGL 3.2 or higher now required for 09/30/2018 update

Postby Ferret » Tue Oct 02, 2018 7:17 pm

Eeek! :( That would be frowny indeed, but let's try a few things first:

What OS are you on?
User avatar
Ferret
 
Posts: 1663
Joined: Tue Sep 16, 2014 3:18 pm

Re: OpenGL 3.2 or higher now required for 09/30/2018 update

Postby ShinQuickMan » Tue Oct 02, 2018 11:44 pm

Debian Linux 64-bit (Mint, to be exact).
ShinQuickMan
 
Posts: 5
Joined: Tue Oct 02, 2018 6:25 pm

Re: OpenGL 3.2 or higher now required for 09/30/2018 update

Postby Ferret » Wed Oct 03, 2018 1:16 am

Ugh... that doesn't actually leave many options. :( Crap, crap, crap. This was what I was afraid of with upgrading Unity versions.

The only thing I can find is that it seems I have the ability to make Linux builds that support something called Vulkan instead of OpenGL, but the option is labelled as Experimental within Unity. I confess to knowing little about it, but if your computer can support it and you're willing to install it, I can make a build that uses it and we can see what happens.

This page offers links to Vulkan drivers for various video card brands. I don't know what card you have, but might be worth seeing if it is supported by yours:

https://www.khronos.org/vulkan/

Good luck, and I apologize for the trouble. :( I'd been remiss in waiting this long to upgrade (there are some horrifying performance issues with Unity 5 I'd wanted to get away from for some time now, to say nothing of fixing the fullscreen bug.), and part of why I'd hesitated was this very scenario. :(
User avatar
Ferret
 
Posts: 1663
Joined: Tue Sep 16, 2014 3:18 pm

Re: OpenGL 3.2 or higher now required for 09/30/2018 update

Postby ShinQuickMan » Wed Oct 03, 2018 1:59 pm

Alright, I'll give it a shot. As requested, I've the drivers installed.
ShinQuickMan
 
Posts: 5
Joined: Tue Oct 02, 2018 6:25 pm

Re: OpenGL 3.2 or higher now required for 09/30/2018 update

Postby Ferret » Wed Oct 03, 2018 4:58 pm

Awesome. :D I'll make a test build for you and send you a PM on here when I get home tonight (sometime around 7 or 8 Central US time)
User avatar
Ferret
 
Posts: 1663
Joined: Tue Sep 16, 2014 3:18 pm

Re: OpenGL 3.2 or higher now required for 09/30/2018 update

Postby Tchey » Thu Oct 04, 2018 9:12 am

Hello,

I'm on Linux Mint and i have no issue with the 30 sept version so far (and fullscreen is working, haha)
* Mon blog indécent sur les jeux indé... Jeux1d100.net *
User avatar
Tchey
 
Posts: 7
Joined: Sat Feb 17, 2018 10:13 am
Location: Terre ?

Re: OpenGL 3.2 or higher now required for 09/30/2018 update

Postby Ferret » Thu Oct 04, 2018 6:54 pm

I *think* the problem here is an older graphic card, rather than flavor of Linux, but I'd be the first to admit my knowledge of Linux is fairly limited.

This is pretty much the nightmare scenario I've always had about upgrading the Unity version Demon uses. :(
User avatar
Ferret
 
Posts: 1663
Joined: Tue Sep 16, 2014 3:18 pm

Re: OpenGL 3.2 or higher now required for 09/30/2018 update

Postby ShinQuickMan » Thu Oct 04, 2018 11:01 pm

Welp, I gave it a fair shake with the stable vulkan drivers and various alternatives, but couldn't get things to work. Simple tests with WINE and the win version of Demon was likewise kaput.
ShinQuickMan
 
Posts: 5
Joined: Tue Oct 02, 2018 6:25 pm

Re: OpenGL 3.2 or higher now required for 09/30/2018 update

Postby Ferret » Thu Oct 04, 2018 11:38 pm

:(

I appreciate the effort you put into trying the various alternatives. I wish there was more I could do on my end. :( I'm sorry we couldn't find a workaround, forcing someone out like this is the last thing I wanted, but I'd put off the Unity upgrade too long already. I doubt it makes it any better, but for what it's worth, I'm pretty bummed about this. I recognize you from the scoreboards and DF forums; I'd be upset about this happening to anyone, but for it to be someone who's played for quite awhile and has promoted the game just makes it even worse.
User avatar
Ferret
 
Posts: 1663
Joined: Tue Sep 16, 2014 3:18 pm

Next

Return to Bug Reports

Who is online

Users browsing this forum: No registered users and 4 guests

cron